WebSphere 远程代码执行漏洞(CVE-2020-4276、CVE-2020-4362) 通告

摘要:近日,出现WebSphere Application Server远程代码执行漏洞(CVE-2020-4276和CVE-2020-4362)。该漏洞影响WebSphere Application Server 7.0.x - WebSphere Application Server 9.0.x之间多个版本。

 

IBM WebSphere Application Server(WAS)是美国IBM公司的一款应用服务器产品。该产品是JavaEE和Web服务应用程序的平台,也是IBMWebSphere软件平台的基础。该漏洞存在于WebSphere SOAP Connector 服务,未经授权的远程攻击者可通过该漏洞在目标服务器执行任意恶意代码。

一、WebSphere SOAP Connector 是什么服务?

WebSphere SOAP Connector 服务用于管理远程节点和数据同步,因此主要是在服务器与服务器之间进行通信。它的默认监听地址为0.0.0.0:8880。

二、漏洞描述

在远程主机上运行的ibmwebsphereapplicationserver版本为7.0.0.0到7.0.0.45、8.0.0.0到8.0.0.15、8.5.5.18之前的8.5.0.x或9.0.5.4之前的9.0.x。因此,它受到权限提升漏洞的影响。由于未指定的原因,IBM WebSphere应用程序服务器中存在此漏洞。经过身份验证的远程攻击者可以利用此漏洞,通过SOAP连接器上的管理请求中基于令牌的身份验证来获得对系统的特权访问。

三、漏洞概要

漏洞

名称

威胁

类型

威胁等级

漏洞ID

利用场景

受影响系统及应用版本

WebSphere 远程代码执行漏洞

远程代码执行

高危

CVE-2020-4276、CVE-2020-4362

远程且未经授权的攻击者通过利用此漏洞,可以在目标服务端执行任意恶意代码,获取系统权限

WebSphere Application Server 9.0.x

WebSphere Application Server 8.5.x

WebSphere Application Server 8.0.x

WebSphere Application Server 7.0.x

四、影响面评估

对于受漏洞影响的WebSphere 来说,如果攻击者可以访问到其SOAP Connector 服务端口,即存在被漏洞利用的风险(WebSphereSOAP Connector 默认监听地址为0.0.0.0:8880,且此漏洞的利用无额外条件限制)。

由于WebSphere SOAP Connector 主要用于服务器之间的通信,因此多见于企业内网环境中。

五、处置建议

修复方法

1. 目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://www.ibm.com/support/pages/node/6118222

https://www.ibm.com/support/pages/node/6174417

2. IBM官方并未给出漏洞的临时缓解防护办法,如果无法进行补丁更新升级,建议使用雷池WAF并配置自定义规则对该漏洞进行安全防护。

发布者:吴芳   点击数:917   发布时间:2020-04-16 14:47:58   更新时间:2020-04-16 14:56:18